Issue7

Title [pLink] pLink stops after "Search Engine is ready to search"
Priority bug Status finished
Superseder Nosy List Kitty, ctarn
Assigned To ctarn Keywords 链接

Created on 2021-02-11.10:41:47 by Kitty, last changed by ctarn.

Files
File name Uploaded Type Edit Remove
Capture.JPG Kitty, 2021-02-15.07:24:53 image/jpeg
Capture2.JPG Kitty, 2021-02-15.07:31:20 image/jpeg
Capture3.JPG Kitty, 2021-02-15.07:48:20 image/jpeg
Capture4.JPG Kitty, 2021-02-16.15:28:51 image/jpeg
Capture6.JPG Kitty, 2021-02-18.11:05:29 image/jpeg
Capture7.JPG Kitty, 2021-02-18.15:48:37 image/jpeg
custom linker.JPG Kitty, 2021-02-11.10:41:47 image/jpeg
mgf.png ctarn, 2021-02-18.18:13:35 image/png
pLink_task_2021.02.10.16.31.41.plink Kitty, 2021-02-11.10:46:48 application/octet-stream
Messages
msg28 (view) Author: ctarn Date: 2021-02-18.18:13:35
Hi, pLink accepts .mgf files like Figure mgf,png (file 15).
msg27 (view) Author: ctarn Date: 2021-02-18.17:36:56
Hi, according to the screenshot, the .mgf contains no charge information, and pLink 
can’t process such data. If the original .wiff file is available, please try to 
convert the data using pParse. Please also note that, we rarely test pLink on .wiff 
data currently, and the performance can be worse that using Thermo.

pParse is available at http://pfind.org/software/pParse.
msg26 (view) Author: Kitty Date: 2021-02-18.15:48:37
Please see capture7
msg25 (view) Author: ctarn Date: 2021-02-18.15:27:04
Hi, please open the .mgf file with a text editor like Notepad, and send us the 
first few lines. You can also send us the .mgf to plink@ict.ac.cn directly.

Please use .raw file if it is available, and you can also try to convert the 
.mgf to .ms2 format using tools like MsConvert.
msg24 (view) Author: Kitty Date: 2021-02-18.11:05:29
Hi, I have move the folder to a new place and run in cmd gain. Please see the screenshot in capture6. It seem that the .mgf file has some problems too, but I did use the mgf file in other software and it did work. Do you have any idea about the problem?
msg23 (view) Author: ctarn Date: 2021-02-16.15:58:44
Hi, the task folder should not be saved to the installation folder by default. 
The installation folder is located at C disk, and you may have no access to C 
disk when running in normal user mode.

You don't have to re-install pLink currently, although installing pLink to C 
disk can also cause some error in some computer.

Please first try to move the data file and database file to another folder, 
and also create a new task in another folder. The `Desktop`, `Documents`, or 
`Downloads` of your account is recommended, because in most cases you have 
full access to these folders.

If similar error still occurs, you can also try to re-install pLink to another 
disk. The license file can be reused, and no extra application requried.
msg22 (view) Author: Kitty Date: 2021-02-16.15:44:54
The task folder is saved automatically in the installation folder? Should I install the software in a new location? Or remove the data file (.mgf file) and database file to another location different to the instalation folder?
msg21 (view) Author: ctarn Date: 2021-02-16.15:39:16
Hi, it seems that pLink has no access to read/write files in the task folder. 
The folder is located at the C: disk, which is the SYSTEM disk, and may be 
protected by Windows. Please try to create a new task in another folder. The 
desktop folder is recommend.
msg20 (view) Author: Kitty Date: 2021-02-16.15:28:51
Please see the capture 4. It said load parameter fail.
msg19 (view) Author: ctarn Date: 2021-02-16.15:16:17
Please refer to issue 8, run pLink in command line mode, and send us the 
screenshot of the output. You can also send us the .mgf file to plink@ict.ac.cn.
msg16 (view) Author: Kitty Date: 2021-02-15.07:31:20
still not working
msg15 (view) Author: Kitty Date: 2021-02-15.07:24:53
Hi, I did change the file name of data to make it no whitespaces, but still not working.
msg14 (view) Author: ctarn Date: 2021-02-12.13:07:02
Hi, please exclude whitespaces or Non-ASCII symbols from the path or file names of 
data.
“C:\pFindStudio\pLink\2.3.9\data files\BSA\20201217D_DDA_KM70.mgf”
msg13 (view) Author: Kitty Date: 2021-02-11.10:41:47
It stopped after showing the belows
[pLink] Welcome to use pLink v2.3.9, it will be expired on 20230110
[pLink] Search Engine initializing...
[pLink] Generating reverse database...
[pLink] Search identifier: EUCMR
[pLink] Search Engine is ready to search.

[pLink] Start searching C:\pFindStudio\pLink\2.3.9\data files\BSA\20201217D_DDA_KM70.mgf, Labeling None


I have tried to re-install the software and make sure there is no space between characters in the directory. But it is still not working.
History
Date User Action Args
2021-02-21 22:01:18ctarnsetkeyword: + 链接
2021-02-21 21:58:07ctarnsetpriority: urgent -> bug
status: chatting -> finished
title: pLink stops after "Search Engine is ready to search" -> [pLink] pLink stops after "Search Engine is ready to search"
2021-02-18 18:13:39ctarnsetfiles: + mgf.png
messages: + msg28
2021-02-18 17:36:59ctarnsetmessages: + msg27
2021-02-18 15:48:41Kittysetfiles: + Capture7.JPG
messages: + msg26
2021-02-18 15:27:07ctarnsetmessages: + msg25
2021-02-18 11:05:33Kittysetfiles: + Capture6.JPG
messages: + msg24
2021-02-16 15:58:47ctarnsetmessages: + msg23
2021-02-16 15:44:57Kittysetmessages: + msg22
2021-02-16 15:39:19ctarnsetmessages: + msg21
2021-02-16 15:28:55Kittysetfiles: + Capture4.JPG
messages: + msg20
2021-02-16 15:16:20ctarnsetmessages: + msg19
2021-02-15 07:48:20Kittysetfiles: + Capture3.JPG
2021-02-15 07:31:25Kittysetfiles: + Capture2.JPG
messages: + msg16
2021-02-15 07:24:57Kittysetfiles: + Capture.JPG
messages: + msg15
2021-02-12 13:07:06ctarnsetassignedto: ctarn
messages: + msg14
status: unread -> chatting
nosy: + ctarn
2021-02-11 10:46:48Kittysetfiles: + pLink_task_2021.02.10.16.31.41.plink
2021-02-11 10:41:52Kittycreate